php-ext.com / rrd (from pecl using PHP 8.0.5-buster)

Dockerfile
FROM php:8.0.5-buster
WORKDIR /tmp
RUN apt update && \
    apt install -y --no-install-recommends git subversion autoconf build-essential && \
    apt install -y --no-install-recommends librrd-dev && \
    rm -rf /var/lib/apt/lists/*
RUN pecl install --force rrd && \
    pecl run-tests rrd
Build output PASS 16ss
Step 1/4 : FROM php:8.0.5-buster
---> 9d3d64fb1730
Step 2/4 : WORKDIR /tmp
---> Running in e8f20c6619b5
Removing intermediate container e8f20c6619b5
---> 654125c4d5cf
Step 3/4 : RUN apt update && apt install -y --no-install-recommends git subversion autoconf build-essential && apt install -y --no-install-recommends librrd-dev && rm -rf /var/lib/apt/lists/*
---> Running in c1a1020b0f38

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.


Get:1 http://security.debian.org/debian-security buster/updates InRelease [65.4 kB]
Get:2 http://deb.debian.org/debian buster InRelease [121 kB]
Get:3 http://deb.debian.org/debian buster-updates InRelease [51.9 kB]
Get:4 http://security.debian.org/debian-security buster/updates/main amd64 Packages [285 kB]
Get:5 http://deb.debian.org/debian buster/main amd64 Packages [7907 kB]
Get:6 http://deb.debian.org/debian buster-updates/main amd64 Packages [10.9 kB]
Fetched 8441 kB in 2s (5450 kB/s)
Reading package lists...
Building dependency tree...
Reading state information...
2 packages can be upgraded. Run 'apt list --upgradable' to see them.


WARNING: 
apt
 
does not have a stable CLI interface. 
Use with caution in scripts.




Reading package lists...
Building dependency tree...
Reading state information...
autoconf is already the newest version (2.69-11).
The following package was automatically installed and is no longer required:
lsb-base
Use 'apt autoremove' to remove it.
The following additional packages will be installed:
git-man libapr1 libaprutil1 libcurl3-gnutls liberror-perl libexpat1
libpcre2-8-0 libserf-1-1 libsvn1 libutf8proc2
Suggested packages:
gettext-base git-daemon-run | git-daemon-sysvinit git-doc git-el git-email
git-gui gitk gitweb git-cvs git-mediawiki git-svn db5.3-util
libapache2-mod-svn subversion-tools
Recommended packages:
less ssh-client
The following NEW packages will be installed:
build-essential git git-man libapr1 libaprutil1 libcurl3-gnutls
liberror-perl libexpat1 libpcre2-8-0 libserf-1-1 libsvn1 libutf8proc2
subversion
0 upgraded, 13 newly installed, 0 to remove and 2 not upgraded.
Need to get 10.7 MB of archives.
After this operation, 50.2 MB of additional disk space will be used.
Get:1 http://security.debian.org/debian-security buster/updates/main amd64 libcurl3-gnutls amd64 7.64.0-4+deb10u2 [330 kB]
Get:2 http://deb.debian.org/debian buster/main amd64 build-essential amd64 12.6 [7576 B]
Get:3 http://deb.debian.org/debian buster/main amd64 libexpat1 amd64 2.2.6-2+deb10u1 [106 kB]
Get:4 http://deb.debian.org/debian buster/main amd64 libpcre2-8-0 amd64 10.32-5 [213 kB]
Get:5 http://deb.debian.org/debian buster/main amd64 liberror-perl all 0.17027-2 [30.9 kB]
Get:6 http://deb.debian.org/debian buster/main amd64 git-man all 1:2.20.1-2+deb10u3 [1620 kB]
Get:7 http://deb.debian.org/debian buster/main amd64 git amd64 1:2.20.1-2+deb10u3 [5633 kB]
Get:8 http://deb.debian.org/debian buster/main amd64 libapr1 amd64 1.6.5-1+b1 [102 kB]
Get:9 http://deb.debian.org/debian buster/main amd64 libaprutil1 amd64 1.6.1-4 [91.8 kB]
Get:10 http://deb.debian.org/debian buster/main amd64 libserf-1-1 amd64 1.3.9-7+b10 [53.6 kB]
Get:11 http://deb.debian.org/debian buster/main amd64 libutf8proc2 amd64 2.3.0-1 [53.0 kB]
Get:12 http://deb.debian.org/debian buster/main amd64 libsvn1 amd64 1.10.4-1+deb10u2 [1403 kB]
Get:13 http://deb.debian.org/debian buster/main amd64 subversion amd64 1.10.4-1+deb10u2 [1008 kB]
debconf: delaying package configuration, since apt-utils is not installed

Fetched 10.7 MB in 0s (86.7 MB/s)
Selecting previously unselected package build-essential.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ...
12690 files and directories currently installed.)
Preparing to unpack .../00-build-essential_12.6_amd64.deb ...
Unpacking build-essential (12.6) ...
Selecting previously unselected package libcurl3-gnutls:amd64.
Preparing to unpack .../01-libcurl3-gnutls_7.64.0-4+deb10u2_amd64.deb ...
Unpacking libcurl3-gnutls:amd64 (7.64.0-4+deb10u2) ...
Selecting previously unselected package libexpat1:amd64.
Preparing to unpack .../02-libexpat1_2.2.6-2+deb10u1_amd64.deb ...
Unpacking libexpat1:amd64 (2.2.6-2+deb10u1) ...
Selecting previously unselected package libpcre2-8-0:amd64.
Preparing to unpack .../03-libpcre2-8-0_10.32-5_amd64.deb ...
Unpacking libpcre2-8-0:amd64 (10.32-5) ...
Selecting previously unselected package liberror-perl.
Preparing to unpack .../04-liberror-perl_0.17027-2_all.deb ...
Unpacking liberror-perl (0.17027-2) ...
Selecting previously unselected package git-man.
Preparing to unpack .../05-git-man_1%3a2.20.1-2+deb10u3_all.deb ...
Unpacking git-man (1:2.20.1-2+deb10u3) ...
Selecting previously unselected package git.
Preparing to unpack .../06-git_1%3a2.20.1-2+deb10u3_amd64.deb ...
Unpacking git (1:2.20.1-2+deb10u3) ...
Selecting previously unselected package libapr1:amd64.
Preparing to unpack .../07-libapr1_1.6.5-1+b1_amd64.deb ...
Unpacking libapr1:amd64 (1.6.5-1+b1) ...
Selecting previously unselected package libaprutil1:amd64.
Preparing to unpack .../08-libaprutil1_1.6.1-4_amd64.deb ...
Unpacking libaprutil1:amd64 (1.6.1-4) ...
Selecting previously unselected package libserf-1-1:amd64.
Preparing to unpack .../09-libserf-1-1_1.3.9-7+b10_amd64.deb ...
Unpacking libserf-1-1:amd64 (1.3.9-7+b10) ...
Selecting previously unselected package libutf8proc2:amd64.
Preparing to unpack .../10-libutf8proc2_2.3.0-1_amd64.deb ...
Unpacking libutf8proc2:amd64 (2.3.0-1) ...
Selecting previously unselected package libsvn1:amd64.
Preparing to unpack .../11-libsvn1_1.10.4-1+deb10u2_amd64.deb ...
Unpacking libsvn1:amd64 (1.10.4-1+deb10u2) ...
Selecting previously unselected package subversion.
Preparing to unpack .../12-subversion_1.10.4-1+deb10u2_amd64.deb ...
Unpacking subversion (1.10.4-1+deb10u2) ...
Setting up libexpat1:amd64 (2.2.6-2+deb10u1) ...
Setting up libutf8proc2:amd64 (2.3.0-1) ...
Setting up libapr1:amd64 (1.6.5-1+b1) ...
Setting up libcurl3-gnutls:amd64 (7.64.0-4+deb10u2) ...
Setting up liberror-perl (0.17027-2) ...
Setting up libpcre2-8-0:amd64 (10.32-5) ...
Setting up build-essential (12.6) ...
Setting up git-man (1:2.20.1-2+deb10u3) ...
Setting up libaprutil1:amd64 (1.6.1-4) ...
Setting up libserf-1-1:amd64 (1.3.9-7+b10) ...
Setting up git (1:2.20.1-2+deb10u3) ...
Setting up libsvn1:amd64 (1.10.4-1+deb10u2) ...
Setting up subversion (1.10.4-1+deb10u2) ...
Processing triggers for libc-bin (2.28-10) ...


WARNING: 
apt
 
does not have a stable CLI interface. 
Use with caution in scripts.




Reading package lists...
Building dependency tree...
Reading state information...
The following package was automatically installed and is no longer required:
lsb-base
Use 'apt autoremove' to remove it.
The following additional packages will be installed:
fontconfig fontconfig-config fonts-dejavu-core libcairo2 libdatrie1 libdbi1
libfontconfig1 libfreetype6 libfribidi0 libgraphite2-3 libharfbuzz0b
libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpixman-1-0
libpng16-16 librrd8 libthai-data libthai0 libx11-6 libx11-data libxau6
libxcb-render0 libxcb-shm0 libxcb1 libxdmcp6 libxext6 libxrender1
sensible-utils ucf
The following NEW packages will be installed:
fontconfig fontconfig-config fonts-dejavu-core libcairo2 libdatrie1 libdbi1
libfontconfig1 libfreetype6 libfribidi0 libgraphite2-3 libharfbuzz0b
libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpixman-1-0
libpng16-16 librrd-dev librrd8 libthai-data libthai0 libx11-6 libx11-data
libxau6 libxcb-render0 libxcb-shm0 libxcb1 libxdmcp6 libxext6 libxrender1
sensible-utils ucf
0 upgraded, 31 newly installed, 0 to remove and 2 not upgraded.
Need to get 8082 kB of archives.
After this operation, 18.0 MB of additional disk space will be used.
Get:1 http://deb.debian.org/debian buster/main amd64 sensible-utils all 0.0.12 [15.8 kB]
Get:2 http://deb.debian.org/debian buster/main amd64 ucf all 3.0038+nmu1 [69.0 kB]
Get:3 http://deb.debian.org/debian buster/main amd64 libpng16-16 amd64 1.6.36-6 [292 kB]
Get:4 http://deb.debian.org/debian buster/main amd64 libfreetype6 amd64 2.9.1-3+deb10u2 [380 kB]
Get:5 http://deb.debian.org/debian buster/main amd64 fonts-dejavu-core all 2.37-1 [1068 kB]
Get:6 http://deb.debian.org/debian buster/main amd64 fontconfig-config all 2.13.1-2 [280 kB]
Get:7 http://deb.debian.org/debian buster/main amd64 libfontconfig1 amd64 2.13.1-2 [346 kB]
Get:8 http://deb.debian.org/debian buster/main amd64 fontconfig amd64 2.13.1-2 [405 kB]
Get:9 http://deb.debian.org/debian buster/main amd64 libpixman-1-0 amd64 0.36.0-1 [537 kB]
Get:10 http://deb.debian.org/debian buster/main amd64 libxau6 amd64 1:1.0.8-1+b2 [19.9 kB]
Get:11 http://deb.debian.org/debian buster/main amd64 libxdmcp6 amd64 1:1.1.2-3 [26.3 kB]
Get:12 http://deb.debian.org/debian buster/main amd64 libxcb1 amd64 1.13.1-2 [137 kB]
Get:13 http://deb.debian.org/debian buster/main amd64 libx11-data all 2:1.6.7-1+deb10u1 [294 kB]
Get:14 http://deb.debian.org/debian buster/main amd64 libx11-6 amd64 2:1.6.7-1+deb10u1 [757 kB]
Get:15 http://deb.debian.org/debian buster/main amd64 libxcb-render0 amd64 1.13.1-2 [109 kB]
Get:16 http://deb.debian.org/debian buster/main amd64 libxcb-shm0 amd64 1.13.1-2 [99.2 kB]
Get:17 http://deb.debian.org/debian buster/main amd64 libxext6 amd64 2:1.3.3-1+b2 [52.5 kB]
Get:18 http://deb.debian.org/debian buster/main amd64 libxrender1 amd64 1:0.9.10-1 [33.0 kB]
Get:19 http://deb.debian.org/debian buster/main amd64 libcairo2 amd64 1.16.0-4+deb10u1 [688 kB]
Get:20 http://deb.debian.org/debian buster/main amd64 libdatrie1 amd64 0.2.12-2 [39.3 kB]
Get:21 http://deb.debian.org/debian buster/main amd64 libdbi1 amd64 0.9.0-5 [31.9 kB]
Get:22 http://deb.debian.org/debian buster/main amd64 libfribidi0 amd64 1.0.5-3.1+deb10u1 [63.7 kB]
Get:23 http://deb.debian.org/debian buster/main amd64 libgraphite2-3 amd64 1.3.13-7 [80.7 kB]
Get:24 http://deb.debian.org/debian buster/main amd64 libharfbuzz0b amd64 2.3.1-1 [1187 kB]
Get:25 http://deb.debian.org/debian buster/main amd64 libthai-data all 0.1.28-2 [170 kB]
Get:26 http://deb.debian.org/debian buster/main amd64 libthai0 amd64 0.1.28-2 [54.1 kB]
Get:27 http://deb.debian.org/debian buster/main amd64 libpango-1.0-0 amd64 1.42.4-8~deb10u1 [186 kB]
Get:28 http://deb.debian.org/debian buster/main amd64 libpangoft2-1.0-0 amd64 1.42.4-8~deb10u1 [68.3 kB]
Get:29 http://deb.debian.org/debian buster/main amd64 libpangocairo-1.0-0 amd64 1.42.4-8~deb10u1 [55.7 kB]
Get:30 http://deb.debian.org/debian buster/main amd64 librrd8 amd64 1.7.1-2 [253 kB]
Get:31 http://deb.debian.org/debian buster/main amd64 librrd-dev amd64 1.7.1-2 [284 kB]
debconf: delaying package configuration, since apt-utils is not installed

Fetched 8082 kB in 0s (72.4 MB/s)
Selecting previously unselected package sensible-utils.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ...
13812 files and directories currently installed.)
Preparing to unpack .../00-sensible-utils_0.0.12_all.deb ...
Unpacking sensible-utils (0.0.12) ...
Selecting previously unselected package ucf.
Preparing to unpack .../01-ucf_3.0038+nmu1_all.deb ...
Moving old data out of the way
Unpacking ucf (3.0038+nmu1) ...
Selecting previously unselected package libpng16-16:amd64.
Preparing to unpack .../02-libpng16-16_1.6.36-6_amd64.deb ...
Unpacking libpng16-16:amd64 (1.6.36-6) ...
Selecting previously unselected package libfreetype6:amd64.
Preparing to unpack .../03-libfreetype6_2.9.1-3+deb10u2_amd64.deb ...
Unpacking libfreetype6:amd64 (2.9.1-3+deb10u2) ...
Selecting previously unselected package fonts-dejavu-core.
Preparing to unpack .../04-fonts-dejavu-core_2.37-1_all.deb ...
Unpacking fonts-dejavu-core (2.37-1) ...
Selecting previously unselected package fontconfig-config.
Preparing to unpack .../05-fontconfig-config_2.13.1-2_all.deb ...
Unpacking fontconfig-config (2.13.1-2) ...
Selecting previously unselected package libfontconfig1:amd64.
Preparing to unpack .../06-libfontconfig1_2.13.1-2_amd64.deb ...
Unpacking libfontconfig1:amd64 (2.13.1-2) ...
Selecting previously unselected package fontconfig.
Preparing to unpack .../07-fontconfig_2.13.1-2_amd64.deb ...
Unpacking fontconfig (2.13.1-2) ...
Selecting previously unselected package libpixman-1-0:amd64.
Preparing to unpack .../08-libpixman-1-0_0.36.0-1_amd64.deb ...
Unpacking libpixman-1-0:amd64 (0.36.0-1) ...
Selecting previously unselected package libxau6:amd64.
Preparing to unpack .../09-libxau6_1%3a1.0.8-1+b2_amd64.deb ...
Unpacking libxau6:amd64 (1:1.0.8-1+b2) ...
Selecting previously unselected package libxdmcp6:amd64.
Preparing to unpack .../10-libxdmcp6_1%3a1.1.2-3_amd64.deb ...
Unpacking libxdmcp6:amd64 (1:1.1.2-3) ...
Selecting previously unselected package libxcb1:amd64.
Preparing to unpack .../11-libxcb1_1.13.1-2_amd64.deb ...
Unpacking libxcb1:amd64 (1.13.1-2) ...
Selecting previously unselected package libx11-data.
Preparing to unpack .../12-libx11-data_2%3a1.6.7-1+deb10u1_all.deb ...
Unpacking libx11-data (2:1.6.7-1+deb10u1) ...
Selecting previously unselected package libx11-6:amd64.
Preparing to unpack .../13-libx11-6_2%3a1.6.7-1+deb10u1_amd64.deb ...
Unpacking libx11-6:amd64 (2:1.6.7-1+deb10u1) ...
Selecting previously unselected package libxcb-render0:amd64.
Preparing to unpack .../14-libxcb-render0_1.13.1-2_amd64.deb ...
Unpacking libxcb-render0:amd64 (1.13.1-2) ...
Selecting previously unselected package libxcb-shm0:amd64.
Preparing to unpack .../15-libxcb-shm0_1.13.1-2_amd64.deb ...
Unpacking libxcb-shm0:amd64 (1.13.1-2) ...
Selecting previously unselected package libxext6:amd64.
Preparing to unpack .../16-libxext6_2%3a1.3.3-1+b2_amd64.deb ...
Unpacking libxext6:amd64 (2:1.3.3-1+b2) ...
Selecting previously unselected package libxrender1:amd64.
Preparing to unpack .../17-libxrender1_1%3a0.9.10-1_amd64.deb ...
Unpacking libxrender1:amd64 (1:0.9.10-1) ...
Selecting previously unselected package libcairo2:amd64.
Preparing to unpack .../18-libcairo2_1.16.0-4+deb10u1_amd64.deb ...
Unpacking libcairo2:amd64 (1.16.0-4+deb10u1) ...
Selecting previously unselected package libdatrie1:amd64.
Preparing to unpack .../19-libdatrie1_0.2.12-2_amd64.deb ...
Unpacking libdatrie1:amd64 (0.2.12-2) ...
Selecting previously unselected package libdbi1:amd64.
Preparing to unpack .../20-libdbi1_0.9.0-5_amd64.deb ...
Unpacking libdbi1:amd64 (0.9.0-5) ...
Selecting previously unselected package libfribidi0:amd64.
Preparing to unpack .../21-libfribidi0_1.0.5-3.1+deb10u1_amd64.deb ...
Unpacking libfribidi0:amd64 (1.0.5-3.1+deb10u1) ...
Selecting previously unselected package libgraphite2-3:amd64.
Preparing to unpack .../22-libgraphite2-3_1.3.13-7_amd64.deb ...
Unpacking libgraphite2-3:amd64 (1.3.13-7) ...
Selecting previously unselected package libharfbuzz0b:amd64.
Preparing to unpack .../23-libharfbuzz0b_2.3.1-1_amd64.deb ...
Unpacking libharfbuzz0b:amd64 (2.3.1-1) ...
Selecting previously unselected package libthai-data.
Preparing to unpack .../24-libthai-data_0.1.28-2_all.deb ...
Unpacking libthai-data (0.1.28-2) ...
Selecting previously unselected package libthai0:amd64.
Preparing to unpack .../25-libthai0_0.1.28-2_amd64.deb ...
Unpacking libthai0:amd64 (0.1.28-2) ...
Selecting previously unselected package libpango-1.0-0:amd64.
Preparing to unpack .../26-libpango-1.0-0_1.42.4-8~deb10u1_amd64.deb ...
Unpacking libpango-1.0-0:amd64 (1.42.4-8~deb10u1) ...
Selecting previously unselected package libpangoft2-1.0-0:amd64.
Preparing to unpack .../27-libpangoft2-1.0-0_1.42.4-8~deb10u1_amd64.deb ...
Unpacking libpangoft2-1.0-0:amd64 (1.42.4-8~deb10u1) ...
Selecting previously unselected package libpangocairo-1.0-0:amd64.
Preparing to unpack .../28-libpangocairo-1.0-0_1.42.4-8~deb10u1_amd64.deb ...
Unpacking libpangocairo-1.0-0:amd64 (1.42.4-8~deb10u1) ...
Selecting previously unselected package librrd8:amd64.
Preparing to unpack .../29-librrd8_1.7.1-2_amd64.deb ...
Unpacking librrd8:amd64 (1.7.1-2) ...
Selecting previously unselected package librrd-dev:amd64.
Preparing to unpack .../30-librrd-dev_1.7.1-2_amd64.deb ...
Unpacking librrd-dev:amd64 (1.7.1-2) ...
Setting up libgraphite2-3:amd64 (1.3.13-7) ...
Setting up libpixman-1-0:amd64 (0.36.0-1) ...
Setting up libxau6:amd64 (1:1.0.8-1+b2) ...
Setting up libxdmcp6:amd64 (1:1.1.2-3) ...
Setting up libxcb1:amd64 (1.13.1-2) ...
Setting up libdbi1:amd64 (0.9.0-5) ...
Setting up libdatrie1:amd64 (0.2.12-2) ...
Setting up libxcb-render0:amd64 (1.13.1-2) ...
Setting up libxcb-shm0:amd64 (1.13.1-2) ...
Setting up libx11-data (2:1.6.7-1+deb10u1) ...
Setting up libfribidi0:amd64 (1.0.5-3.1+deb10u1) ...
Setting up libpng16-16:amd64 (1.6.36-6) ...
Setting up fonts-dejavu-core (2.37-1) ...
Setting up sensible-utils (0.0.12) ...
Setting up libx11-6:amd64 (2:1.6.7-1+deb10u1) ...
Setting up libthai-data (0.1.28-2) ...
Setting up libxrender1:amd64 (1:0.9.10-1) ...
Setting up libxext6:amd64 (2:1.3.3-1+b2) ...
Setting up libthai0:amd64 (0.1.28-2) ...
Setting up libfreetype6:amd64 (2.9.1-3+deb10u2) ...
Setting up ucf (3.0038+nmu1) ...
debconf: unable to initialize frontend: Dialog
debconf: (TERM is not set, so the dialog frontend is not usable.)
debconf: falling back to frontend: Readline
Setting up libharfbuzz0b:amd64 (2.3.1-1) ...
Setting up fontconfig-config (2.13.1-2) ...
debconf: unable to initialize frontend: Dialog
debconf: (TERM is not set, so the dialog frontend is not usable.)
debconf: falling back to frontend: Readline
Setting up libfontconfig1:amd64 (2.13.1-2) ...
Setting up fontconfig (2.13.1-2) ...
Regenerating fonts cache...
done.
Setting up libpango-1.0-0:amd64 (1.42.4-8~deb10u1) ...
Setting up libcairo2:amd64 (1.16.0-4+deb10u1) ...
Setting up libpangoft2-1.0-0:amd64 (1.42.4-8~deb10u1) ...
Setting up libpangocairo-1.0-0:amd64 (1.42.4-8~deb10u1) ...
Setting up librrd8:amd64 (1.7.1-2) ...
Setting up librrd-dev:amd64 (1.7.1-2) ...
Processing triggers for libc-bin (2.28-10) ...
Removing intermediate container c1a1020b0f38
---> f7c9cb283a45
Step 4/4 : RUN pecl install --force rrd && pecl run-tests rrd
---> Running in 1101af4639d1
downloading rrd-2.0.3.tgz ...
Starting to download rrd-2.0.3.tgz (19,178 bytes)
.
.
.
...done: 19,178 bytes
12 source files, building
running: phpize
Configuring for:
PHP Api Version:         20200930
Zend Module Api No:      20200930
Zend Extension Api No:   420200930
building in /tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3
running: /tmp/pear/temp/rrd/configure --with-php-config=/usr/local/bin/php-config
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking target system type... x86_64-pc-linux-gnu
checking for PHP prefix... /usr/local
checking for PHP includes... -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib
checking for PHP extension directory... /usr/local/lib/php/extensions/no-debug-non-zts-20200930
checking for PHP installed headers prefix... /usr/local/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for gawk... no
checking for nawk... nawk
checking if nawk is broken... no
checking for rrdtool support... yes, shared
checking for rrdtool... no
checking for pkg-config... /usr/bin/pkg-config
checking for librdd... found
checking for rrd_lastupdate_r in -lrrd... yes
checking for rrdc_disconnect in -lrrd... yes
checking for a sed that does not truncate output... /bin/sed
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking the maximum length of command line arguments... 1572864
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC
checking if cc PIC flag -fPIC works... yes
checking if cc static flag -static works... yes
checking if cc supports -c -o file.o... yes
checking whether the cc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
creating libtool
appending configuration tag "CXX" to libtool
configure: patching config.h.in
configure: creating ./config.status
config.status: creating config.h
running: make
/bin/bash /tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/libtool --mode=compile cc -I. -I/tmp/pear/temp/rrd -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/include -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/main -I/tmp/pear/temp/rrd -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2    -c /tmp/pear/temp/rrd/rrd.c -o rrd.lo
mkdir .libs
cc -I. -I/tmp/pear/temp/rrd -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/include -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/main -I/tmp/pear/temp/rrd -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/rrd/rrd.c  -fPIC -DPIC -o .libs/rrd.o
/bin/bash /tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/libtool --mode=compile cc -I. -I/tmp/pear/temp/rrd -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/include -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/main -I/tmp/pear/temp/rrd -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2    -c /tmp/pear/temp/rrd/rrd_graph.c -o rrd_graph.lo
cc -I. -I/tmp/pear/temp/rrd -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/include -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/main -I/tmp/pear/temp/rrd -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/rrd/rrd_graph.c  -fPIC -DPIC -o .libs/rrd_graph.o
/bin/bash /tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/libtool --mode=compile cc -I. -I/tmp/pear/temp/rrd -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/include -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/main -I/tmp/pear/temp/rrd -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2    -c /tmp/pear/temp/rrd/rrd_create.c -o rrd_create.lo
cc -I. -I/tmp/pear/temp/rrd -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/include -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/main -I/tmp/pear/temp/rrd -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/rrd/rrd_create.c  -fPIC -DPIC -o .libs/rrd_create.o
/bin/bash /tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/libtool --mode=compile cc -I. -I/tmp/pear/temp/rrd -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/include -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/main -I/tmp/pear/temp/rrd -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2    -c /tmp/pear/temp/rrd/rrd_update.c -o rrd_update.lo
cc -I. -I/tmp/pear/temp/rrd -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/include -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/main -I/tmp/pear/temp/rrd -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/rrd/rrd_update.c  -fPIC -DPIC -o .libs/rrd_update.o
/bin/bash /tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/libtool --mode=compile cc -I. -I/tmp/pear/temp/rrd -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/include -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/main -I/tmp/pear/temp/rrd -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2    -c /tmp/pear/temp/rrd/rrd_info.c -o rrd_info.lo
cc -I. -I/tmp/pear/temp/rrd -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/include -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/main -I/tmp/pear/temp/rrd -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/rrd/rrd_info.c  -fPIC -DPIC -o .libs/rrd_info.o
/bin/bash /tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/libtool --mode=link cc -shared -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/include -I/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/main -I/tmp/pear/temp/rrd -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2    -o rrd.la -export-dynamic -avoid-version -prefer-pic -module -rpath /tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/modules  rrd.lo rrd_graph.lo rrd_create.lo rrd_update.lo rrd_info.lo -lrrd
cc -shared  .libs/rrd.o .libs/rrd_graph.o .libs/rrd_create.o .libs/rrd_update.o .libs/rrd_info.o  -lrrd  -Wl,-soname -Wl,rrd.so -o .libs/rrd.so
creating rrd.la
(cd .libs && rm -f rrd.la && ln -s ../rrd.la rrd.la)
/bin/bash /tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/libtool --mode=install cp ./rrd.la /tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/modules
cp ./.libs/rrd.so /tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/modules/rrd.so
cp ./.libs/rrd.lai /tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/modules/rrd.la
PATH="$PATH:/sbin" ldconfig -n /tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/modules
----------------------------------------------------------------------
Libraries have been installed in:
/tmp/pear/temp/pear-build-defaultuserRLgG7r/rrd-2.0.3/modules
If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
- add LIBDIR to the `LD_LIBRARY_PATH' environment variable
during execution
- add LIBDIR to the `LD_RUN_PATH' environment variable
during linking
- use the `-Wl,--rpath -Wl,LIBDIR' linker flag
- have your system administrator add LIBDIR to `/etc/ld.so.conf'
See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
Build complete.
Don't forget to run 'make test'.
running: make INSTALL_ROOT="/tmp/pear/temp/pear-build-defaultuserRLgG7r/install-rrd-2.0.3" install
Installing shared extensions:     /tmp/pear/temp/pear-build-defaultuserRLgG7r/install-rrd-2.0.3/usr/local/lib/php/extensions/no-debug-non-zts-20200930/
running: find "/tmp/pear/temp/pear-build-defaultuserRLgG7r/install-rrd-2.0.3" | xargs ls -dils
1280220   4 drwxr-xr-x 3 root root   4096 Apr 30 01:37 /tmp/pear/temp/pear-build-defaultuserRLgG7r/install-rrd-2.0.3
1280249   4 drwxr-xr-x 3 root root   4096 Apr 30 01:37 /tmp/pear/temp/pear-build-defaultuserRLgG7r/install-rrd-2.0.3/usr
1280250   4 drwxr-xr-x 3 root root   4096 Apr 30 01:37 /tmp/pear/temp/pear-build-defaultuserRLgG7r/install-rrd-2.0.3/usr/local
1280251   4 drwxr-xr-x 3 root root   4096 Apr 30 01:37 /tmp/pear/temp/pear-build-defaultuserRLgG7r/install-rrd-2.0.3/usr/local/lib
1280252   4 drwxr-xr-x 3 root root   4096 Apr 30 01:37 /tmp/pear/temp/pear-build-defaultuserRLgG7r/install-rrd-2.0.3/usr/local/lib/php
1280253   4 drwxr-xr-x 3 root root   4096 Apr 30 01:37 /tmp/pear/temp/pear-build-defaultuserRLgG7r/install-rrd-2.0.3/usr/local/lib/php/extensions
1280254   4 drwxr-xr-x 2 root root   4096 Apr 30 01:37 /tmp/pear/temp/pear-build-defaultuserRLgG7r/install-rrd-2.0.3/usr/local/lib/php/extensions/no-debug-non-zts-20200930
1280247 256 -rwxr-xr-x 1 root root 262128 Apr 30 01:37 /tmp/pear/temp/pear-build-defaultuserRLgG7r/install-rrd-2.0.3/usr/local/lib/php/extensions/no-debug-non-zts-20200930/rrd.so
Build process completed successfully
Installing '/usr/local/lib/php/extensions/no-debug-non-zts-20200930/rrd.so'
install ok: channel://pecl.php.net/rrd-2.0.3
configuration option "php_ini" is not set to php.ini location
You should add "extension=rrd.so" to php.ini
Running 0 tests
TOTAL TIME: 00:00
0 PASSED TESTS
0 SKIPPED TESTS
Removing intermediate container 1101af4639d1
---> 7dab65322e43
Successfully built 7dab65322e43