php-ext.com / swoole_serialize (from pecl using PHP 7.4.16-zts-buster)

Dockerfile
FROM php:7.4.16-zts-buster
WORKDIR /tmp
RUN apt update && \
    apt install -y --no-install-recommends git subversion autoconf build-essential && \
    rm -rf /var/lib/apt/lists/*
RUN pecl install --force swoole_serialize && \
    pecl run-tests swoole_serialize
Build output FAIL 13ss
Step 1/4 : FROM php:7.4.16-zts-buster
---> f100431f0b6a
Step 2/4 : WORKDIR /tmp
---> Running in 65f5543c04c6
Removing intermediate container 65f5543c04c6
---> a9a32d4758b0
Step 3/4 : RUN apt update && apt install -y --no-install-recommends git subversion autoconf build-essential && rm -rf /var/lib/apt/lists/*
---> Running in f0e054f099e1


WARNING: 
apt
 
does not have a stable CLI interface. 
Use with caution in scripts.




Get:1 http://security.debian.org/debian-security buster/updates InRelease [65.4 kB]
Get:2 http://deb.debian.org/debian buster InRelease [122 kB]
Get:3 http://security.debian.org/debian-security buster/updates/main amd64 Packages [268 kB]
Get:4 http://deb.debian.org/debian buster-updates InRelease [51.9 kB]
Get:5 http://deb.debian.org/debian buster/main amd64 Packages [7907 kB]
Get:6 http://deb.debian.org/debian buster-updates/main amd64 Packages [9504 B]
Fetched 8423 kB in 3s (2762 kB/s)
Reading package lists...
Building dependency tree...
Reading state information...
1 package can be upgraded. Run 'apt list --upgradable' to see it.


WARNING: 
apt
 
does not have a stable CLI interface. 
Use with caution in scripts.




Reading package lists...
Building dependency tree...
Reading state information...
autoconf is already the newest version (2.69-11).
The following package was automatically installed and is no longer required:
lsb-base
Use 'apt autoremove' to remove it.
The following additional packages will be installed:
git-man libapr1 libaprutil1 libcurl3-gnutls liberror-perl libexpat1
libpcre2-8-0 libserf-1-1 libsvn1 libutf8proc2
Suggested packages:
gettext-base git-daemon-run | git-daemon-sysvinit git-doc git-el git-email
git-gui gitk gitweb git-cvs git-mediawiki git-svn db5.3-util
libapache2-mod-svn subversion-tools
Recommended packages:
less ssh-client
The following NEW packages will be installed:
build-essential git git-man libapr1 libaprutil1 libcurl3-gnutls
liberror-perl libexpat1 libpcre2-8-0 libserf-1-1 libsvn1 libutf8proc2
subversion
0 upgraded, 13 newly installed, 0 to remove and 1 not upgraded.
Need to get 10.7 MB of archives.
After this operation, 50.2 MB of additional disk space will be used.
Get:1 http://security.debian.org/debian-security buster/updates/main amd64 libsvn1 amd64 1.10.4-1+deb10u2 [1403 kB]
Get:2 http://deb.debian.org/debian buster/main amd64 build-essential amd64 12.6 [7576 B]
Get:3 http://deb.debian.org/debian buster/main amd64 libcurl3-gnutls amd64 7.64.0-4+deb10u1 [330 kB]
Get:4 http://deb.debian.org/debian buster/main amd64 libexpat1 amd64 2.2.6-2+deb10u1 [106 kB]
Get:5 http://deb.debian.org/debian buster/main amd64 libpcre2-8-0 amd64 10.32-5 [213 kB]
Get:6 http://deb.debian.org/debian buster/main amd64 liberror-perl all 0.17027-2 [30.9 kB]
Get:7 http://deb.debian.org/debian buster/main amd64 git-man all 1:2.20.1-2+deb10u3 [1620 kB]
Get:8 http://security.debian.org/debian-security buster/updates/main amd64 subversion amd64 1.10.4-1+deb10u2 [1008 kB]
Get:9 http://deb.debian.org/debian buster/main amd64 git amd64 1:2.20.1-2+deb10u3 [5633 kB]
Get:10 http://deb.debian.org/debian buster/main amd64 libapr1 amd64 1.6.5-1+b1 [102 kB]
Get:11 http://deb.debian.org/debian buster/main amd64 libaprutil1 amd64 1.6.1-4 [91.8 kB]
Get:12 http://deb.debian.org/debian buster/main amd64 libserf-1-1 amd64 1.3.9-7+b10 [53.6 kB]
Get:13 http://deb.debian.org/debian buster/main amd64 libutf8proc2 amd64 2.3.0-1 [53.0 kB]
debconf: delaying package configuration, since apt-utils is not installed

Fetched 10.7 MB in 1s (7584 kB/s)
Selecting previously unselected package build-essential.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ...
12690 files and directories currently installed.)
Preparing to unpack .../00-build-essential_12.6_amd64.deb ...
Unpacking build-essential (12.6) ...
Selecting previously unselected package libcurl3-gnutls:amd64.
Preparing to unpack .../01-libcurl3-gnutls_7.64.0-4+deb10u1_amd64.deb ...
Unpacking libcurl3-gnutls:amd64 (7.64.0-4+deb10u1) ...
Selecting previously unselected package libexpat1:amd64.
Preparing to unpack .../02-libexpat1_2.2.6-2+deb10u1_amd64.deb ...
Unpacking libexpat1:amd64 (2.2.6-2+deb10u1) ...
Selecting previously unselected package libpcre2-8-0:amd64.
Preparing to unpack .../03-libpcre2-8-0_10.32-5_amd64.deb ...
Unpacking libpcre2-8-0:amd64 (10.32-5) ...
Selecting previously unselected package liberror-perl.
Preparing to unpack .../04-liberror-perl_0.17027-2_all.deb ...
Unpacking liberror-perl (0.17027-2) ...
Selecting previously unselected package git-man.
Preparing to unpack .../05-git-man_1%3a2.20.1-2+deb10u3_all.deb ...
Unpacking git-man (1:2.20.1-2+deb10u3) ...
Selecting previously unselected package git.
Preparing to unpack .../06-git_1%3a2.20.1-2+deb10u3_amd64.deb ...
Unpacking git (1:2.20.1-2+deb10u3) ...
Selecting previously unselected package libapr1:amd64.
Preparing to unpack .../07-libapr1_1.6.5-1+b1_amd64.deb ...
Unpacking libapr1:amd64 (1.6.5-1+b1) ...
Selecting previously unselected package libaprutil1:amd64.
Preparing to unpack .../08-libaprutil1_1.6.1-4_amd64.deb ...
Unpacking libaprutil1:amd64 (1.6.1-4) ...
Selecting previously unselected package libserf-1-1:amd64.
Preparing to unpack .../09-libserf-1-1_1.3.9-7+b10_amd64.deb ...
Unpacking libserf-1-1:amd64 (1.3.9-7+b10) ...
Selecting previously unselected package libutf8proc2:amd64.
Preparing to unpack .../10-libutf8proc2_2.3.0-1_amd64.deb ...
Unpacking libutf8proc2:amd64 (2.3.0-1) ...
Selecting previously unselected package libsvn1:amd64.
Preparing to unpack .../11-libsvn1_1.10.4-1+deb10u2_amd64.deb ...
Unpacking libsvn1:amd64 (1.10.4-1+deb10u2) ...
Selecting previously unselected package subversion.
Preparing to unpack .../12-subversion_1.10.4-1+deb10u2_amd64.deb ...
Unpacking subversion (1.10.4-1+deb10u2) ...
Setting up libexpat1:amd64 (2.2.6-2+deb10u1) ...
Setting up libutf8proc2:amd64 (2.3.0-1) ...
Setting up libapr1:amd64 (1.6.5-1+b1) ...
Setting up libcurl3-gnutls:amd64 (7.64.0-4+deb10u1) ...
Setting up liberror-perl (0.17027-2) ...
Setting up libpcre2-8-0:amd64 (10.32-5) ...
Setting up build-essential (12.6) ...
Setting up git-man (1:2.20.1-2+deb10u3) ...
Setting up libaprutil1:amd64 (1.6.1-4) ...
Setting up libserf-1-1:amd64 (1.3.9-7+b10) ...
Setting up git (1:2.20.1-2+deb10u3) ...
Setting up libsvn1:amd64 (1.10.4-1+deb10u2) ...
Setting up subversion (1.10.4-1+deb10u2) ...
Processing triggers for libc-bin (2.28-10) ...
Removing intermediate container f0e054f099e1
---> 0e028c4ad206
Step 4/4 : RUN pecl install --force swoole_serialize && pecl run-tests swoole_serialize
---> Running in 5fe838e52245
WARNING: failed to download pecl.php.net/swoole_serialize within preferred state "stable", will instead download version 0.1.1, stability "beta"
downloading swoole_serialize-0.1.1.tgz ...
Starting to download swoole_serialize-0.1.1.tgz (17,304 bytes)
.
.
.
...done: 17,304 bytes
4 source files, building
running: phpize
Configuring for:
PHP Api Version:         20190902
Zend Module Api No:      20190902
Zend Extension Api No:   320190902
building in /tmp/pear/temp/pear-build-defaultuserGVafp5/swoole_serialize-0.1.1
running: /tmp/pear/temp/swoole_serialize/configure --with-php-config=/usr/local/bin/php-config
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking target system type... x86_64-pc-linux-gnu
checking for PHP prefix... /usr/local
checking for PHP includes... -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib
checking for PHP extension directory... /usr/local/lib/php/extensions/no-debug-zts-20190902
checking for PHP installed headers prefix... /usr/local/include/php
checking if debug is enabled... no
checking if zts is enabled... yes
checking for gawk... no
checking for nawk... nawk
checking if nawk is broken... no
checking whether to enable swoole_serialize support... yes, shared
checking for a sed that does not truncate output... /bin/sed
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking the maximum length of command line arguments... 1572864
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC
checking if cc PIC flag -fPIC works... yes
checking if cc static flag -static works... yes
checking if cc supports -c -o file.o... yes
checking whether the cc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
creating libtool
appending configuration tag "CXX" to libtool
configure: patching config.h.in
configure: creating ./config.status
config.status: creating config.h
running: make
/bin/bash /tmp/pear/temp/pear-build-defaultuserGVafp5/swoole_serialize-0.1.1/libtool --mode=compile cc -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -I. -I/tmp/pear/temp/swoole_serialize -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-defaultuserGVafp5/swoole_serialize-0.1.1/include -I/tmp/pear/temp/pear-build-defaultuserGVafp5/swoole_serialize-0.1.1/main -I/tmp/pear/temp/swoole_serialize -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/temp/swoole_serialize/swoole_serialize.c -o swoole_serialize.lo
mkdir .libs
cc -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -I. -I/tmp/pear/temp/swoole_serialize -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-defaultuserGVafp5/swoole_serialize-0.1.1/include -I/tmp/pear/temp/pear-build-defaultuserGVafp5/swoole_serialize-0.1.1/main -I/tmp/pear/temp/swoole_serialize -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/swoole_serialize/swoole_serialize.c  -fPIC -DPIC -o .libs/swoole_serialize.o
/tmp/pear/temp/swoole_serialize/swoole_serialize.c: In function 'swoole_unserialize_arr':
/tmp/pear/temp/swoole_serialize/swoole_serialize.c:352:19: error: 'HASH_FLAG_APPLY_PROTECTION' undeclared (first use in this function); did you mean 'HASH_FLAG_HAS_EMPTY_IND'?
ht->u.flags = HASH_FLAG_APPLY_PROTECTION;
^~~~~~~~~~~~~~~~~~~~~~~~~~
HASH_FLAG_HAS_EMPTY_IND
/tmp/pear/temp/swoole_serialize/swoole_serialize.c:352:19: note: each undeclared identifier is reported only once for each function it appears in
/tmp/pear/temp/swoole_serialize/swoole_serialize.c:356:21: error: lvalue required as left operand of assignment
GC_REFCOUNT(ht) = 1;
^
/tmp/pear/temp/swoole_serialize/swoole_serialize.c:362:24: error: 'HASH_FLAG_INITIALIZED' undeclared (first use in this function); did you mean 'HASH_FLAG_UNINITIALIZED'?
ht->u.flags |= HASH_FLAG_INITIALIZED;
^~~~~~~~~~~~~~~~~~~~~
HASH_FLAG_UNINITIALIZED
/tmp/pear/temp/swoole_serialize/swoole_serialize.c: In function 'swoole_serialize_arr':
/tmp/pear/temp/swoole_serialize/swoole_serialize.c:674:21: warning: implicit declaration of function 'ZEND_HASH_GET_APPLY_COUNT'; did you mean 'ZEND_HASH_APPLY_KEEP'? [-Wimplicit-function-declaration]
if (ZEND_HASH_GET_APPLY_COUNT(ht) > 1)
^~~~~~~~~~~~~~~~~~~~~~~~~
ZEND_HASH_APPLY_KEEP
/tmp/pear/temp/swoole_serialize/swoole_serialize.c:681:25: warning: implicit declaration of function 'ZEND_HASH_APPLY_PROTECTION'; did you mean 'ZEND_HASH_APPLY_REMOVE'? [-Wimplicit-function-declaration]
if (ZEND_HASH_APPLY_PROTECTION(ht))
^~~~~~~~~~~~~~~~~~~~~~~~~~
ZEND_HASH_APPLY_REMOVE
/tmp/pear/temp/swoole_serialize/swoole_serialize.c:683:25: warning: implicit declaration of function 'ZEND_HASH_INC_APPLY_COUNT'; did you mean 'ZEND_HASH_APPLY_KEEP'? [-Wimplicit-function-declaration]
ZEND_HASH_INC_APPLY_COUNT(ht);
^~~~~~~~~~~~~~~~~~~~~~~~~
ZEND_HASH_APPLY_KEEP
/tmp/pear/temp/swoole_serialize/swoole_serialize.c:685:25: warning: implicit declaration of function 'ZEND_HASH_DEC_APPLY_COUNT'; did you mean 'ZEND_HASH_APPLY_KEEP'? [-Wimplicit-function-declaration]
ZEND_HASH_DEC_APPLY_COUNT(ht);
^~~~~~~~~~~~~~~~~~~~~~~~~
ZEND_HASH_APPLY_KEEP
/tmp/pear/temp/swoole_serialize/swoole_serialize.c: In function 'swoole_serialize_object':
/tmp/pear/temp/swoole_serialize/swoole_serialize.c:781:9: warning: implicit declaration of function 'zend_throw_exception_ex'; did you mean 'zend_try_exception_handler'? [-Wimplicit-function-declaration]
zend_throw_exception_ex(NULL, 0, "the object %s have cycle ref!", name->val);
^~~~~~~~~~~~~~~~~~~~~~~
zend_try_exception_handler
/tmp/pear/temp/swoole_serialize/swoole_serialize.c:821:32: error: 'HASH_FLAG_INITIALIZED' undeclared (first use in this function); did you mean 'HASH_FLAG_UNINITIALIZED'?
ht->u.flags |= HASH_FLAG_INITIALIZED;
^~~~~~~~~~~~~~~~~~~~~
HASH_FLAG_UNINITIALIZED
/tmp/pear/temp/swoole_serialize/swoole_serialize.c:840:29: warning: implicit declaration of function '_zend_hash_add_or_update'; did you mean 'zend_hash_add_or_update'? [-Wimplicit-function-declaration]
_zend_hash_add_or_update(ht, prop_key, prop_value, HASH_UPDATE ZEND_FILE_LINE_RELAY_CC);
^~~~~~~~~~~~~~~~~~~~~~~~
zend_hash_add_or_update
/tmp/pear/temp/swoole_serialize/swoole_serialize.c: In function 'php_swoole_serialize':
/tmp/pear/temp/swoole_serialize/swoole_serialize.c:1087:24: error: lvalue required as left operand of assignment
GC_REFCOUNT(z_str) = 1;
^
make: *** [Makefile:191: swoole_serialize.lo] Error 1
ERROR: `make' failed